AutoCorrect funkcije

AutoCorrect funkcije u ONLYOFFICE Document Editor-u se koriste za automatsko formatiranje teksta kada se otkrije obrazac ili za umetanje posebnih matematičkih simbola prepoznavanjem određenih karaktera.

Dostupne opcije AutoCorrect-a prikazane su u odgovarajućem dijalogu. Da biste mu pristupili, idite na File karticu -> Napredna podešavanja -> Proofing -> AutoCorrect opcije.

Dijalog AutoCorrect se sastoji od četiri taba: Math Autocorrect, Recognized Functions, AutoFormat As You Type, i Text AutoCorrect.

Math AutoCorrect

Kada radite sa jednačinama, možete umetnuti veliki broj simbola, akcenata i znakova matematičkih operacija tako što ih otkucate na tastaturi, umesto da birate šablon iz galerije.

U editoru jednačina, postavite kursor u odgovarajući placeholder, otkucajte math autocorrect kod, zatim pritisnite Spacebar. Uneti kod će biti konvertovan u odgovarajući simbol, a razmak će biti uklonjen.

Napomena: Kodovi su osetljivi na velika i mala slova.

Možete dodavati, menjati, vraćati i uklanjati AutoCorrect unose iz liste AutoCorrect. Idite na File karticu -> Advanced Settings -> Proofing -> AutoCorrect Options -> Math AutoCorrect.

Dodavanje unosa u AutoCorrect listu

Izmena unosa u AutoCorrect listi

Uklanjanje unosa sa AutoCorrect liste

Da biste vratili prethodno obrisane unose, izaberite unos sa liste i kliknite na Restore dugme.

Koristite Reset to default dugme da vratite podrazumevana podešavanja. Svi AutoCorrect unosi koje ste dodali biće uklonjeni, a promenjeni vraćeni na originalne vrednosti.

Da biste onemogućili Math AutoCorrect i izbegli automatske promene i zamene, uklonite ček sa Replace text as you type opcije.

Replace text as you type

Tabela ispod sadrži sve trenutno podržane kodove dostupne u Document Editor. Puna lista podržanih kodova takođe se može pronaći na File kartici -> Advanced Settings -> Proofing -> AutoCorrect Options -> Math AutoCorrect.

Podržani kodovi
Kod Simbol Kategorija
!!
Simboli
...
Tačke
::
Operatori
:=
Operatori
/<
Relacioni operatori
/>
Relacioni operatori
/=
Relacioni operatori
\above
Skripte iznad/ispod
\acute
Akcenti
\aleph
Hebrejska slova
\alpha
Grčka slova
\Alpha
Grčka slova
\amalg
Binarni operatori
\angle
Geometrijska notacija
\aoint
Integrali
\approx
Relacioni operatori
\asmash
Strelice
\ast
Binarni operatori
\asymp
Relacioni operatori
\atop
Operatori
\bar
Nadcrta/podcrta
\Bar
Akcenti
\because
Relacioni operatori
\begin
Razdvajači
\below
Skripte iznad/ispod
\bet
Hebrejska slova
\beta
Grčka slova
\Beta
Grčka slova
\beth
Hebrejska slova
\bigcap
Veliki operatori
\bigcup
Veliki operatori
\bigodot
Veliki operatori
\bigoplus
Veliki operatori
\bigotimes
Veliki operatori
\bigsqcup
Veliki operatori
\biguplus
Veliki operatori
\bigvee
Veliki operatori
\bigwedge
Veliki operatori
\binomial
Jednačine
\bot
Logička notacija
\bowtie
Relacioni operatori
\box
Simboli
\boxdot
Binarni operatori
\boxminus
Binarni operatori
\boxplus
Binarni operatori
\bra
Razdvajači
\break
Simboli
\breve
Akcenti
\bullet
Binarni operatori
\cap
Binarni operatori
\cbrt
Kubni koreni i radikali
\cases
Simboli
\cdot
Binarni operatori
\cdots
Tačke
\check
Akcenti
\chi
Grčka slova
\Chi
Grčka slova
\circ
Binarni operatori
\close
Razdvajači
\clubsuit
Simboli
\coint
Integrali
\cong
Relacioni operatori
\coprod
Matematički operatori
\cup
Binarni operatori
\dalet
Hebrejska slova
\daleth
Hebrejska slova
\dashv
Relacioni operatori
\dd
Dvostruko potezana slova
\Dd
Dvostruko potezana slova
\ddddot
Akcenti
\dddot
Akcenti
\ddot
Akcenti
\ddots
Tačke
\defeq
Relacioni operatori
\degc
Simboli
\degf
Simboli
\degree
Simboli
\delta
Grčka slova
\Delta
Grčka slova
\Deltaeq
Operatori
\diamond
Binarni operatori
\diamondsuit
Simboli
\div
Binarni operatori
\dot
Akcenti
\doteq
Relacioni operatori
\dots
Tačke
\doublea
Dvostruko potezana slova
\doubleA
Dvostruko potezana slova
\doubleb
Dvostruko potezana slova
\doubleB
Dvostruko potezana slova
\doublec
Dvostruko potezana slova
\doubleC
Dvostruko potezana slova
\doubled
Dvostruko potezana slova
\doubleD
Dvostruko potezana slova
\doublee
Dvostruko potezana slova
\doubleE
Dvostruko potezana slova
\doublef
Dvostruko potezana slova
\doubleF
Dvostruko potezana slova
\doubleg
Dvostruko potezana slova
\doubleG
Dvostruko potezana slova
\doubleh
Dvostruko potezana slova
\doubleH
Dvostruko potezana slova
\doublei
Dvostruko potezana slova
\doubleI
Dvostruko potezana slova
\doublej
Dvostruko potezana slova
\doubleJ
Dvostruko potezana slova
\doublek
Dvostruko potezana slova
\doubleK
Dvostruko potezana slova
\doublel
Dvostruko potezana slova
\doubleL
Dvostruko potezana slova
\doublem
Dvostruko potezana slova
\doubleM
Dvostruko potezana slova
\doublen
Dvostruko potezana slova
\doubleN
Dvostruko potezana slova
\doubleo
Dvostruko potezana slova
\doubleO
Dvostruko potezana slova
\doublep
Dvostruko potezana slova
\doubleP
Dvostruko potezana slova
\doubleq
Dvostruko potezana slova
\doubleQ
Dvostruko potezana slova
\doubler
Dvostruko potezana slova
\doubleR
Dvostruko potezana slova
\doubles
Dvostruko potezana slova
\doubleS
Dvostruko potezana slova
\doublet
Dvostruko potezana slova
\doubleT
Dvostruko potezana slova
\doubleu
Dvostruko potezana slova
\doubleU
Dvostruko potezana slova
\doublev
Dvostruko potezana slova
\doubleV
Dvostruko potezana slova
\doublew
Dvostruko potezana slova
\doubleW
Dvostruko potezana slova
\doublex
Dvostruko potezana slova
\doubleX
Dvostruko potezana slova
\doubley
Dvostruko potezana slova
\doubleY
Dvostruko potezana slova
\doublez
Dvostruko potezana slova
\doubleZ
Dvostruko potezana slova
\downarrow
Strelice
\Downarrow
Strelice
\dsmash
Strelice
\ee
Dvostruko potezana slova
\ell
Simboli
\emptyset
Oznake skupova
\emsp Znakovi razmaka
\end
Razdelnici
\ensp Znakovi razmaka
\epsilon
Grčka slova
\Epsilon
Grčka slova
\eqarray
Simboli
\equiv
Relacioni operatori
\eta
Grčka slova
\Eta
Grčka slova
\exists
Logičke notacije
\forall
Logičke notacije
\fraktura
Fraktur slova
\frakturA
Fraktur slova
\frakturb
Fraktur slova
\frakturB
Fraktur slova
\frakturc
Fraktur slova
\frakturC
Fraktur slova
\frakturd
Fraktur slova
\frakturD
Fraktur slova
\frakture
Fraktur slova
\frakturE
Fraktur slova
\frakturf
Fraktur slova
\frakturF
Fraktur slova
\frakturg
Fraktur slova
\frakturG
Fraktur slova
\frakturh
Fraktur slova
\frakturH
Fraktur slova
\frakturi
Fraktur slova
\frakturI
Fraktur slova
\frakturk
Fraktur slova
\frakturK
Fraktur slova
\frakturl
Fraktur slova
\frakturL
Fraktur slova
\frakturm
Fraktur slova
\frakturM
Fraktur slova
\frakturn
Fraktur slova
\frakturN
Fraktur slova
\frakturo
Fraktur slova
\frakturO
Fraktur slova
\frakturp
Fraktur slova
\frakturP
Fraktur slova
\frakturq
Fraktur slova
\frakturQ
Fraktur slova
\frakturr
Fraktur slova
\frakturR
Fraktur slova
\frakturs
Fraktur slova
\frakturS
Fraktur slova
\frakturt
Fraktur slova
\frakturT
Fraktur slova
\frakturu
Fraktur slova
\frakturU
Fraktur slova
\frakturv
Fraktur slova
\frakturV
Fraktur slova
\frakturw
Fraktur slova
\frakturW
Fraktur slova
\frakturx
Fraktur slova
\frakturX
Fraktur slova
\fraktury
Fraktur slova
\frakturY
Fraktur slova
\frakturz
Fraktur slova
\frakturZ
Fraktur slova
\frown
Relacioni operatori
\funcapply Binarni operatori
\G
Grčka slova
\gamma
Grčka slova
\Gamma
Grčka slova
\ge
Relacioni operatori
\geq
Relacioni operatori
\gets
Strelice
\gg
Relacioni operatori
\gimel
Hebrejska slova
\grave
Akcenti
\hairsp Razmaci
\hat
Akcenti
\hbar
Simboli
\heartsuit
Simboli
\hookleftarrow
Strelice
\hookrightarrow
Strelice
\hphantom
Strelice
\hsmash
Strelice
\hvec
Akcenti
\identitymatrix
Matrice
\ii
Dvostruko precrtana slova
\iiint
Integrali
\iint
Integrali
\iiiint
Integrali
\Im
Simboli
\imath
Simboli
\in
Relacioni operatori
\inc
Simboli
\infty
Simboli
\int
Integrali
\integral
Integrali
\iota
Grčka slova
\Iota
Grčka slova
\itimes Matematički operatori
\j
Simboli
\jj
Dvostruko precrtana slova
\jmath
Simboli
\kappa
Grčka slova
\Kappa
Grčka slova
\ket
Razdvajači
\lambda
Grčka slova
\Lambda
Grčka slova
\langle
Razdvajači
\lbbrack
Razdvajači
\lbrace
Razdvajači
\lbrack
Razdvajači
\lceil
Razdvajači
\ldiv
Razlomačke kose crte
\ldivide
Razlomačke kose crte
\ldots
Tačke
\le
Relacioni operatori
\left
Razdvajači
\leftarrow
Strelice
\Leftarrow
Strelice
\leftharpoondown
Strelice
\leftharpoonup
Strelice
\leftrightarrow
Strelice
\Leftrightarrow
Strelice
\leq
Relacioni operatori
\lfloor
Razdvajači
\lhvec
Akcenti
\limit
Granice
\ll
Relacioni operatori
\lmoust
Razdvajači
\Longleftarrow
Strelice
\Longleftrightarrow
Strelice
\Longrightarrow
Strelice
\lrhar
Strelice
\lvec
Akcenti
\mapsto
Strelice
\matrix
Matrice
\medsp Razmaci
\mid
Relacioni operatori
\middle
Simboli
\models
Relacioni operatori
\mp
Binarni operatori
\mu
Grčka slova
\Mu
Grčka slova
\nabla
Simboli
\naryand
Operatori
\nbsp Razmaci
\ne
Relacioni operatori
\nearrow
Strelice
\neq
Relacioni operatori
\ni
Relacioni operatori
\norm
Razdvajači
\notcontain
Relacioni operatori
\notelement
Relacioni operatori
\notin
Relacioni operatori
\nu
Grčka slova
\Nu
Grčka slova
\nwarrow
Strelice
\o
Grčka slova
\O
Grčka slova
\odot
Binarni operatori
\of
Operatori
\oiiint
Integrali
\oiint
Integrali
\oint
Integrali
\omega
Grčka slova
\Omega
Grčka slova
\ominus
Binarni operatori
\open
Razdvajači
\oplus
Binarni operatori
\otimes
Binarni operatori
\over
Razdvajači
\overbar
Akcenti
\overbrace
Akcenti
\overbracket
Akcenti
\overline
Akcenti
\overparen
Akcenti
\overshell
Akcenti
\parallel
Geometrijska notacija
\partial
Simboli
\pmatrix
Matrice
\perp
Geometrijska notacija
\phantom
Simboli
\phi
Grčka slova
\Phi
Grčka slova
\pi
Grčka slova
\Pi
Grčka slova
\pm
Binarni operatori
\pppprime
Primovi
\ppprime
Primovi
\pprime
Primovi
\prec
Relacijski operatori
\preceq
Relacijski operatori
\prime
Primovi
\prod
Matematički operatori
\propto
Relacijski operatori
\psi
Grčka slova
\Psi
Grčka slova
\qdrt
Koreni i radikali
\quadratic
Kvadratni koreni i radikali
\rangle
Razdvajači
\Rangle
Razdvajači
\ratio
Relacioni operatori
\rbrace
Razdvajači
\rbrack
Razdvajači
\Rbrack
Razdvajači
\rceil
Razdvajači
\rddots
Tačke
\Re
Simboli
\rect
Simboli
\rfloor
Razdvajači
\rho
Grčka slova
\Rho
Grčka slova
\rhvec
Akcenti
\right
Razdvajači
\rightarrow
Strelice
\Rightarrow
Strelice
\rightharpoondown
Strelice
\rightharpoonup
Strelice
\rmoust
Razdvajači
\root
Simboli
\scripta
Skripte
\scriptA
Skripte
\scriptb
Skripte
\scriptB
Skripte
\scriptc
Skripte
\scriptC
Skripte
\scriptd
Skripte
\scriptD
Skripte
\scripte
Skripte
\scriptE
Skripte
\scriptf
Skripte
\scriptF
Skripte
\scriptg
Skripte
\scriptG
Skripte
\scripth
Skripte
\scriptH
Skripte
\scripti
Skripte
\scriptI
Skripte
\scriptk
Skripte
\scriptK
Skripte
\scriptl
Skripte
\scriptL
Skripte
\scriptm
Skripte
\scriptM
Skripte
\scriptn
Skripte
\scriptN
Skripte
\scripto
Skripte
\scriptO
Skripte
\scriptp
Skripte
\scriptP
Skripte
\scriptq
Skripte
\scriptQ
Skripte
\scriptr
Skripte
\scriptR
Skripte
\scripts
Skripte
\scriptS
Skripte
\scriptt
Skripte
\scriptT
Skripte
\scriptu
Skripte
\scriptU
Skripte
\scriptv
Skripte
\scriptV
Skripte
\scriptw
Skripte
\scriptW
Skripte
\scriptx
Skripte
\scriptX
Skripte
\scripty
Skripte
\scriptY
Skripte
\scriptz
Skripte
\scriptZ
Skripte
\sdiv
Razlomačke kose crte
\sdivide
Razlomačke kose crte
\searrow
Strelice
\setminus
Binarni operatori
\sigma
Grčka slova
\Sigma
Grčka slova
\sim
Relacioni operatori
\simeq
Relacioni operatori
\smash
Strelice
\smile
Relacioni operatori
\spadesuit
Simboli
\sqcap
Binarni operatori
\sqcup
Binarni operatori
\sqrt
Kvadratni koreni i radikali
\sqsubseteq
Notacija skupova
\sqsuperseteq
Notacija skupova
\star
Binarni operatori
\subset
Notacija skupova
\subseteq
Notacija skupova
\succ
Relacioni operatori
\succeq
Relacioni operatori
\sum
Matematički operatori
\superset
Notacija skupova
\superseteq
Notacija skupova
\swarrow
Strelice
\tau
Grčka slova
\Tau
Grčka slova
\therefore
Relacioni operatori
\theta
Grčka slova
\Theta
Grčka slova
\thicksp Razmaci
\thinsp Razmaci
\tilde
Akcenti
\times
Binarni operatori
\to
Strelice
\top
Logička notacija
\tvec
Strelice
\ubar
Akcenti
\Ubar
Akcenti
\underbar
Akcenti
\underbrace
Akcenti
\underbracket
Akcenti
\underline
Akcenti
\underparen
Akcenti
\uparrow
Strelice
\Uparrow
Strelice
\updownarrow
Strelice
\Updownarrow
Strelice
\uplus
Binarni operatori
\upsilon
Grčka slova
\Upsilon
Grčka slova
\varepsilon
Grčka slova
\varphi
Grčka slova
\varpi
Grčka slova
\varrho
Grčka slova
\varsigma
Grčka slova
\vartheta
Grčka slova
\vbar
Razdvajači
\vdash
Relacioni operatori
\vdots
Tačke
\vec
Akcenti
\vee
Binarni operatori
\vert
Razdvajači
\Vert
Razdvajači
\Vmatrix
Matrice
\vphantom
Strelice
\vthicksp Razmaci
\wedge
Binarni operatori
\wp
Simboli
\wr
Binarni operatori
\xi
Grčka slova
\Xi
Grčka slova
\zeta
Grčka slova
\Zeta
Grčka slova
\zwnj Razmaci
\zwsp Razmaci
~=
Relacioni operatori
-+
Binarni operatori
+-
Binarni operatori
<<
Relacioni operatori
<=
Relacioni operatori
->
Strelice
>=
Relacioni operatori
>>
Relacioni operatori

Prepoznate funkcije

U ovoj kartici ćete pronaći listu matematičkih izraza koje će uređivač jednačina prepoznati kao funkcije i stoga neće biti automatski napisani kurzivom. Za listu prepoznatih funkcija idite na karticu Datoteka -> Napredna podešavanja -> Lektura -> Opcije automatskog ispravljanja -> Prepoznate funkcije.

Da biste dodali unos na listu prepoznatih funkcija, unesite funkciju u prazno polje i kliknite na dugme Dodaj.

Da biste uklonili unos sa liste prepoznatih funkcija, izaberite funkciju koju želite da uklonite i kliknite na dugme Obriši.

Da biste vratili prethodno obrisane unose, izaberite unos koji želite da vratite sa liste i kliknite na dugme Vrati.

Koristite dugme Vrati na podrazumevano da biste vratili podrazumevana podešavanja. Svaka funkcija koju ste dodali biće uklonjena, a uklonjene će biti vraćene.

Recognized Functions

Automatsko formatiranje tokom kucanja

Podrazumevano, uređivač formatira tekst dok kucate prema unapred podešenim podešavanjima za automatsko formatiranje: zamenjuje navodnike, pretvara crtice u crtice, pretvara tekst prepoznat kao internet ili mrežnu putanju u hiperlink, pokreće listu sa tačkama ili numerisanu listu kada se otkrije lista.

Opcija Dodaj tačku sa dvostrukim razmakom omogućava dodavanje tačke kada dvaput dodirnete razmaknicu. Omogućite je ili onemogućite po potrebi. Podrazumevano, ova opcija je onemogućena za Linux i Windows, a omogućena je za macOS.

Da biste omogućili ili onemogućili unapred podešena podešavanja za automatsko formatiranje, idite na karticu Datoteka -> Napredna podešavanja -> Provera -> Opcije automatskog ispravljanja -> Automatsko formatiranje tokom kucanja.

AutoFormat As You Type

Tekst AutoCorrect

Možete podesiti editor da automatski kapitalizuje prvu reč svake rečenice. Opcija je po defaultu omogućena. Da biste onemogućili ovu opciju, idite na File tab -> Advanced Settings -> Proofing -> AutoCorrect Options -> Text AutoCorrect i uklonite ček sa opcije Capitalize first letter of sentences.

Editor po defaultu kapitalizuje prvo slovo ćelija u tabeli. Da biste onemogućili ovu opciju, idite na File tab -> Advanced Settings -> Proofing -> AutoCorrect Options -> Text AutoCorrect i uklonite ček sa opcije Capitalize first letter of table cells.

Takođe možete prilagoditi kapitalizaciju nakon određenih reči tako što ćete uneti željene reči u polje Don't capitalize after i kliknuti na dugme Add, ili izabrati reči iz odgovarajuće liste ispod.

Možete odabrati kako će izuzeci funkcionisati prema jeziku u padajućem meniju Exceptions for the language.

Koristite dugme Reset to default da poništite sve prilagođene promene.

AutoCorrect